import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(X...?)\\1X|^(...)*XXX|^..X.X.X";
final String string = "XXX \n"
+ " XXX \n"
+ " XXX\n\n"
+ "X X X \n"
+ " X X X \n"
+ " X X X\n\n"
+ "X X X\n"
+ " X X X \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}