#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?s): \[.+?\r?\n \]"
Local $sString = ""before"" & @CRLF & _
": [" & @CRLF & _
" {" & @CRLF & _
" "yearGroupId": 13," & @CRLF & _
" "educationPhaseEnum": 2," & @CRLF & _
" "name": "Year Group 12"," & @CRLF & _
" "label": "YG 12"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "yearGroupId": 14," & @CRLF & _
" "educationPhaseEnum": 2," & @CRLF & _
" "name": "Year Group 13"," & @CRLF & _
" "label": "YG 13"" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
""after"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")