re = /(?s): \[.+?\r?\n \]/i
str = '"before"
: [
{
"yearGroupId": 13,
"educationPhaseEnum": 2,
"name": "Year Group 12",
"label": "YG 12"
},
{
"yearGroupId": 14,
"educationPhaseEnum": 2,
"name": "Year Group 13",
"label": "YG 13"
}
]
"after"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end