use strict;
my $str = '"before"
: [
{
"yearGroupId": 13,
"educationPhaseEnum": 2,
"name": "Year Group 12",
"label": "YG 12"
},
{
"yearGroupId": 14,
"educationPhaseEnum": 2,
"name": "Year Group 13",
"label": "YG 13"
}
]
"after"
';
my $regex = qr/(?s): \[.+?\r?\n \]/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}