#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)abc"
Local $sString = "abc" & @CRLF & _
"abc" & @CRLF & _
"abc" & @CRLF & _
"sda" & @CRLF & _
"asdasd" & @CRLF & _
"sad" & @CRLF & _
"sd" & @CRLF & _
"s" & @CRLF & _
"d" & @CRLF & _
"sad" & @CRLF & _
"asd" & @CRLF & _
"" & @CRLF & _
"asd" & @CRLF & _
"sabc" & @CRLF & _
"abc" & @CRLF & _
"asdsad" & @CRLF & _
"sd" & @CRLF & _
"s" & @CRLF & _
"d" & @CRLF & _
"sad" & @CRLF & _
"sa" & @CRLF & _
"dsad"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")