re = /abc/m
str = 'abc
abc
abc
sda
asdasd
sad
sd
s
d
sad
asd
asd
sabc
abc
asdsad
sd
s
d
sad
sa
dsad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end