package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)abc`)
var str = `abc
abc
abc
sda
asdasd
sad
sd
s
d
sad
asd
asd
sabc
abc
asdsad
sd
s
d
sad
sa
dsad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}