#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.+?)(?:\.x|\.y)?"
Local $sString = "company" & @CRLF & _
"deriv.x" & @CRLF & _
"isConfirmed.y"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)