use strict;
my $str = 'company
deriv.x
isConfirmed.y';
my $regex = qr/(.+?)(?:\.x|\.y)?/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";