using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)(?:\.x|\.y)?";
string substitution = @"$1";
string input = @"company
deriv.x
isConfirmed.y";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}