re = /(.+?)(?:\.x|\.y)?/m
str = 'company
deriv.x
isConfirmed.y'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result