import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "A\\[(?<A>.+)\\]\\sB\\[(?<B>.+)\\]\\sC\\[(?<C>.+)\\]";
final String string = "A[1020/09/09] B[1013/09/09] C[05-07-00000000-000-A-B-C]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}