use strict;
my $str = 'A[1020/09/09] B[1013/09/09] C[05-07-00000000-000-A-B-C]';
my $regex = qr/A\[(?<A>.+)\]\sB\[(?<B>.+)\]\sC\[(?<C>.+)\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}