re = /A\[(?<A>.+)\]\sB\[(?<B>.+)\]\sC\[(?<C>.+)\]/m
str = 'A[1020/09/09] B[1013/09/09] C[05-07-00000000-000-A-B-C]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end