package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/domen\.ru\/wp-content\/uploads\/(.*?)\.jpg`)
var str = `https://domen.ru/wp-content/uploads/1.jpg dsdgf sdfkgjsdkfl;jsdfg https://drugoidomen.ru/wp-content/uploads/222.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}