const regex = /https:\/\/domen\.ru\/wp-content\/uploads\/(.*?)\.jpg/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/domen\\.ru\\\/wp-content\\\/uploads\\\/(.*?)\\.jpg', 'gm')
const str = `https://domen.ru/wp-content/uploads/1.jpg dsdgf sdfkgjsdkfl;jsdfg https://drugoidomen.ru/wp-content/uploads/222.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}