re = /https:\/\/domen\.ru\/wp-content\/uploads\/(.*?)\.jpg/m
str = 'https://domen.ru/wp-content/uploads/1.jpg dsdgf sdfkgjsdkfl;jsdfg https://drugoidomen.ru/wp-content/uploads/222.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end