$re = '/https:\/\/domen\.ru\/wp-content\/uploads\/(.*?)\.jpg/m';
$str = 'https://domen.ru/wp-content/uploads/1.jpg dsdgf sdfkgjsdkfl;jsdfg https://drugoidomen.ru/wp-content/uploads/222.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);