$re = '/([\d,]+)[\s\D]*([\d,]+)[\s\D]*([\d,]+)[\s\D]*/';
$str = '23,6 x 34 x 17,1
14,5 x 55 x 22
14,5cm x 55 x 22cm
14,5cmx55x22cm
14,5 cmx55 cmx22 cm
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);