import re
regex = re.compile(r"([\d,]+)[\s\D]*([\d,]+)[\s\D]*([\d,]+)[\s\D]*")
test_str = ("23,6 x 34 x 17,1\n"
"14,5 x 55 x 22\n"
"14,5cm x 55 x 22cm\n"
"14,5cmx55x22cm\n"
"14,5 cmx55 cmx22 cm\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")