#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<sign>-?)(?<first>\d+(?=\d{6}))?(?<last>\d+)"
Local $sString = "-123456789" & @CRLF & _
"123456789" & @CRLF & _
"-23456789" & @CRLF & _
"56789" & @CRLF & _
"-89"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")