import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<sign>-?)(?<first>\\d+(?=\\d{6}))?(?<last>\\d+)";
final String string = "-123456789\n"
+ "123456789\n"
+ "-23456789\n"
+ "56789\n"
+ "-89";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}