$re = '/(?<sign>-?)(?<first>\d+(?=\d{6}))?(?<last>\d+)/';
$str = '-123456789
123456789
-23456789
56789
-89';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);