re = /(?<sign>-?)(?<first>\d+(?=\d{6}))?(?<last>\d+)/
str = '-123456789
123456789
-23456789
56789
-89'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end