using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"The field \'(\w+)\' is not valid for this request type \'([a-z|A-Z|(0-9)*|\s+]*)\'";
string input = @"The field 'customfield_12583' is not valid for this request type 'Side Tasks'
The field 'customfield_22222' is not valid for this request type 'NOC'
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}