const regex = new RegExp('The field \\\\'(\\w+)\\\\' is not valid for this request type \\\\'([a-z|A-Z|(0-9)*|\\s+]*)\\\\'', 'gm')
const str = `The field 'customfield_12583' is not valid for this request type 'Side Tasks'
The field 'customfield_22222' is not valid for this request type 'NOC'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}