import re
regex = re.compile(r"The field \'(\w+)\' is not valid for this request type \'([a-z|A-Z|(0-9)*|\s+]*)\'", flags=re.MULTILINE)
test_str = ("The field 'customfield_12583' is not valid for this request type 'Side Tasks'\n\n"
"The field 'customfield_22222' is not valid for this request type 'NOC'\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")