re = /The field \'(\w+)\' is not valid for this request type \'([a-z|A-Z|(0-9)*|\s+]*)\'/m
str = 'The field \'customfield_12583\' is not valid for this request type \'Side Tasks\'
The field \'customfield_22222\' is not valid for this request type \'NOC\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end