#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*\|\s*(?:\d+\s*\|)?"
Local $sString = "| 4655748765321 | _jeffybion5 | John Dutch |abc| 123 |"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)