const regex = new RegExp('\\s*\\|\\s*(?:\\d+\\s*\\|)?', 'gm')
const str = `| 4655748765321 | _jeffybion5 | John Dutch |abc| 123 |`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);