using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\|\s*(?:\d+\s*\|)?";
string substitution = @" ";
string input = @"| 4655748765321 | _jeffybion5 | John Dutch |abc| 123 |";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}