import re
regex = re.compile(r"\s*\|\s*(?:\d+\s*\|)?", flags=re.MULTILINE)
test_str = "| 4655748765321 | _jeffybion5 | John Dutch |abc| 123 |"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)