import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[a-zA-Z0-9]+)? ?(?:[Ll]ist|[Tt]able|[Ff]igure)).*?((?:[0-9]+\\-[0-9]+)|(?<!-)[0-9]+): (.*)";
final String string = "Text Table 6-2: Management of children study and actions\n"
+ "Table 6-2: Management of children study and actions\n"
+ "table 6-2: Management of children study and actions\n"
+ "tezt Text Table 6-22: Management of children study and actions\n"
+ "Tezt text table 66-2: Management of children study and actions\n"
+ "tezt Text List / 6-2: Management of children study and actions\n"
+ "Text list 6-2: Management of children study and actions\n"
+ "Table 6-2: Management of children study and actions\n"
+ "table 6-2: Management of children study and actions\n"
+ "tezt Text figure 6-22: Management of children study and actions\n"
+ "Tezt text Figure 66-2: Management of children study and actions\n"
+ "tezt Text Table / 6-2: Management of children study and actions\n"
+ "table: 66-22: Management of children study and actions\n"
+ "tezt Text Table 6-22: Management of children study and actions\n"
+ "tezt Text Table 6: Management of children study and actions\n"
+ "able 6-2: Management of children study and actions\n"
+ "re hable 6-2: Management of children study and actions\n"
+ "table 62: Management of children study and actions\n"
+ "table 62-: Management of children study and actions\n"
+ "table -2: Management of children study and actions\n\n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}