use strict;
my $str = 'Text Table 6-2: Management of children study and actions
Table 6-2: Management of children study and actions
table 6-2: Management of children study and actions
tezt Text Table 6-22: Management of children study and actions
Tezt text table 66-2: Management of children study and actions
tezt Text List / 6-2: Management of children study and actions
Text list 6-2: Management of children study and actions
Table 6-2: Management of children study and actions
table 6-2: Management of children study and actions
tezt Text figure 6-22: Management of children study and actions
Tezt text Figure 66-2: Management of children study and actions
tezt Text Table / 6-2: Management of children study and actions
table: 66-22: Management of children study and actions
tezt Text Table 6-22: Management of children study and actions
tezt Text Table 6: Management of children study and actions
able 6-2: Management of children study and actions
re hable 6-2: Management of children study and actions
table 62: Management of children study and actions
table 62-: Management of children study and actions
table -2: Management of children study and actions
';
my $regex = qr/((?:[a-zA-Z0-9]+)? ?(?:[Ll]ist|[Tt]able|[Ff]igure)).*?((?:[0-9]+\-[0-9]+)|(?<!-)[0-9]+): (.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}