import Foundation
let pattern = #"((?:[a-zA-Z0-9]+)? ?(?:[Ll]ist|[Tt]able|[Ff]igure)).*?((?:[0-9]+\-[0-9]+)|(?<!-)[0-9]+): (.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Text Table 6-2: Management of children study and actions
Table 6-2: Management of children study and actions
table 6-2: Management of children study and actions
tezt Text Table 6-22: Management of children study and actions
Tezt text table 66-2: Management of children study and actions
tezt Text List / 6-2: Management of children study and actions
Text list 6-2: Management of children study and actions
Table 6-2: Management of children study and actions
table 6-2: Management of children study and actions
tezt Text figure 6-22: Management of children study and actions
Tezt text Figure 66-2: Management of children study and actions
tezt Text Table / 6-2: Management of children study and actions
table: 66-22: Management of children study and actions
tezt Text Table 6-22: Management of children study and actions
tezt Text Table 6: Management of children study and actions
able 6-2: Management of children study and actions
re hable 6-2: Management of children study and actions
table 62: Management of children study and actions
table 62-: Management of children study and actions
table -2: Management of children study and actions
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)