#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:a(?:b(?:cd?)?)?)+$"
Local $sString = "a" & @CRLF & _
"abc" & @CRLF & _
"ab" & @CRLF & _
"babcd" & @CRLF & _
"aaaa" & @CRLF & _
"baa" & @CRLF & _
"the" & @CRLF & _
"acd" & @CRLF & _
"ad" & @CRLF & _
"cd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")