package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:a(?:b(?:cd?)?)?)+$`)
var str = `a
abc
ab
babcd
aaaa
baa
the
acd
ad
cd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}