import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:a(?:b(?:cd?)?)?)+$";
final String string = "a\n"
+ "abc\n"
+ "ab\n"
+ "babcd\n"
+ "aaaa\n"
+ "baa\n"
+ "the\n"
+ "acd\n"
+ "ad\n"
+ "cd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}