using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z_0-9\\]+";
string input = @"Interactiv4\CourseProduct\Model\Product\Type\Course
4nteractiv4\CourseProduct\Model\Product\Type\Course
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}