$re = '/[a-zA-Z_0-9\\\\]+/';
$str = 'Interactiv4\\CourseProduct\\Model\\Product\\Type\\Course
4nteractiv4\\CourseProduct\\Model\\Product\\Type\\Course
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);