re = /[a-zA-Z_0-9\\]+/
str = 'Interactiv4\\CourseProduct\\Model\\Product\\Type\\Course
4nteractiv4\\CourseProduct\\Model\\Product\\Type\\Course
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end