import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z_0-9\\\\]+";
final String string = "Interactiv4\\CourseProduct\\Model\\Product\\Type\\Course\n"
+ "4nteractiv4\\CourseProduct\\Model\\Product\\Type\\Course\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}