using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\w+ [^>]*\w+=""([^""]*?blah[^""]*)""";
string input = @"<link rel=""stylesheet"" type=""blah/css"" href=""/BLAH/Test/Test/Test.css""> <script src=""/blah/Test/Test/Test.js""></script>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}