$re = '/<\w+ [^>]*\w+="([^"]*?blah[^"]*)"/mi';
$str = '<link rel="stylesheet" type="blah/css" href="/BLAH/Test/Test/Test.css"> <script src="/blah/Test/Test/Test.js"></script>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);