re = /<\w+ [^>]*\w+="([^"]*?blah[^"]*)"/mi
str = '<link rel="stylesheet" type="blah/css" href="/BLAH/Test/Test/Test.css"> <script src="/blah/Test/Test/Test.js"></script>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end