using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\w+(?:\.|\b)){3}";
string input = @"AAAA cccc.google.com BBBB
;kasjdlksajd www.google.com adsad
;lkasd regex101.com adsad
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}