re = /(?:\w+(?:\.|\b)){3}/m
str = 'AAAA cccc.google.com BBBB
;kasjdlksajd www.google.com adsad
;lkasd regex101.com adsad
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end