package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\w+(?:\.|\b)){3}`)
var str = `AAAA cccc.google.com BBBB
;kasjdlksajd www.google.com adsad
;lkasd regex101.com adsad
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}