#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<div class=\"textbkStyle\">Renewal/Expiration Date:\s*<div class=\"responseText\">\s*(\d{2}/\d{2}/\d{4})\s*</div>\s*</div>"
Local $sString = " <div class="textbkStyle">Renewal/Expiration Date:" & @CRLF & _
" <div class="responseText">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" 01/01/2019" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
"<div class="textbkStyle">Renewal/Expiration Date:" & @CRLF & _
" <div class="responseText">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" NOT AVAILABLE" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")