// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<div class=\"textbkStyle\">Renewal/Expiration Date:\s*<div class=\"responseText\">\s*(\d{2}/\d{2}/\d{4})\s*</div>\s*</div>"#).unwrap();
let string = " <div class=\"textbkStyle\">Renewal/Expiration Date:
<div class=\"responseText\">
01/01/2019
</div>
</div>
<div class=\"textbkStyle\">Renewal/Expiration Date:
<div class=\"responseText\">
NOT AVAILABLE
</div>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}